Beiträge durchsuchen

slic3r –gui und debian testing/unstable

slic3r startet normal nur nicht mit der Option –gui

mig@fast:~$ slic3r --gui
Can't locate Wx.pm in @INC (you may need to install the Wx module) (@INC contains: /usr/bin/lib /etc/perl /usr/local/lib/x86_64-linux-gnu/perl/5.22.2 /usr/local/share/perl/5.22.2 /usr/lib/x86_64-linux-gnu/perl5/5.22 /usr/share/perl5 /usr/lib/x86_64-linux-gnu/perl/5.22 /usr/share/perl/5.22 /usr/local/lib/site_perl /usr/lib/x86_64-linux-gnu/perl-base .) at /usr/share/perl5/Slic3r/GUI/AboutDialog.pm line 6.
BEGIN failed--compilation aborted at /usr/share/perl5/Slic3r/GUI/AboutDialog.pm line 6.
Compilation failed in require at /usr/share/perl5/Slic3r/GUI.pm line 8.
BEGIN failed--compilation aborted at /usr/share/perl5/Slic3r/GUI.pm line 8.
Compilation failed in require at (eval 80) line 1.


Lösung ist das nachinstallieren der opengl-perl Bindings.
apt-get install libopengl-perl
Dann fehlen noch die opengl-libwx Abhängigkeiten die derzeit unter testing/unstable nicht installierbar sind.

apt-get -t experimental install libwx-perl libwx-glcanvas-perl

Nun steht dem slicen nichts mehr im weg
Happy 3d-printing

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.